Integrating with Mercury Quality Center

CaliberRM 2008 SP1

Borland
I

Table of Contents

Introduction ................................................................. 1
Setting Up the Integration ............................................... 1
    Configuring the Integration ........................................ 1
    Enabling the Integration in CaliberRM............................ 3
Using the Mercury Integration ........................................... 3
    Important change in Mercury traceability....................... 4
    Linking Requirements to Mercury Objects........................ 4
    Viewing Traces to Mercury Objects in the CaliberRM Traceability Views ........................................... 5
    Reporting on Quality Center Requirements and Test Execution Status ........................................... 5
Creating Quality Center Tests From CaliberRM Requirements .......... 6
Creating Quality Center Requirements From CaliberRM Requirements ...... 7
Introduction

This integration is designed to ensure that testers validate the system against the latest state of requirements. The integration provides you with a seamlessly integrated, best-of-breed software delivery toolset that spans various phases and roles in the application lifecycle. The integration allows you to leverage the strengths of two industry leaders, and enables bidirectional information flow between analysts and testers. This flow helps increase overall communication, efficiency, and quality in the software delivery process.

CaliberRM contributes to making software a more managed business process by enabling teams to capture and manage the requirements, resources, tasks, timelines, and assets within the software development cycle. The alignment of these assets and phases can be a critical factor to the success or failure of software projects.

The Mercury integration features:

- CaliberRM Mercury Traceability – allows you to trace CaliberRM requirements to Mercury requirements, tests and test sets.
- CaliberRM Test Wizard – creates Mercury tests from CaliberRM requirements and ensures that all requirements are tested by giving the up-to-date status on requirements that have or do not have associated tests.
- CaliberRM Publish Requirements Wizard – creates Mercury requirements from CaliberRM requirements.

With this integration, analysts benefit from:

- Viewing the test status within CaliberRM – provides an analyst with a requirement validation status.
- Assessing requirement coverage – provides an analyst a way to measure how many requirements have been validated and how many requirements are left to validate.
- Reporting on test execution status from CaliberRM.

Testers benefit from:

- Reusing requirements description text in test creation and starting the evaluation of test assets from requirements design by using the Test Wizard.
- Testing against the latest state of requirements.

In this release, the Mercury Publish Requirements and Test Wizards cannot be run in batch mode.

Setting Up the Integration

There are two steps involved in configuring the integration.

- Configuring the integration
- Enabling the integration for individual CaliberRM projects

Configuring the Integration

For Mercury versions that CaliberRM supports refer to the compatibility matrix in the Readme file.

Note: From a CaliberRM requirement, you can establish traces to objects in any supported versions of Quality Center. However only the traces established with the Quality Center version identical to the Quality Center connectivity add-in version installed in your machine will be displayed. For other traces, this message will be displayed: "Quality Center libraries installed are incompatible with Quality Center version you are trying to connect to. CaliberRM may not work with this server."

Before configuring the integration each user that needs to add, edit, or see Quality Center traces should install the Mercury Connectivity Add-in on the CaliberRM client machine.

Note: You should not be logged in as the local user to install the Quality Center connectivity addins.
To install Mercury Connectivity Add-in:

1. Using a Web browser, enter http://[host:port]/qcbin, where host is your Quality Center server name and port is the port location for the server. The Login screen displays.
3. Select Mercury Quality Center Connectivity for Quality Center.
4. Read the information and select Download Add-in. The File Download dialog box displays.
5. Click Open. The files are installed.

Note: If you store your Mercury assets in a database other than MS Access, you may need to install additional components on the Mercury server to allow communication with the database (see your Mercury documentation for more information).

Warning! Migrating your Mercury database to another server using the Mercury Export/Import changes the Mercury Object IDs and invalidates Requirement-to-Test traceability relationships. Please contact CaliberRM support for information about how to minimize the impact of relocating your database.

To edit Quality Center configuration:

1. In the CaliberRM Administrator, select View > Projects from the menu.
2. Select the project for which you want to edit the Mercury configuration.
3. Select the External Traceability tab.
4. Select Quality Center and click Edit. The Edit Integration dialog box opens.
5. Click Modify to edit the contents of the configuration file in the Configuration for 'Quality Center' Integration text editor. You can specify the addresses of one or more Mercury servers of a single version. Add a second line if it does not exist to specify the version of Quality Center you are using. The syntax of this line is version.N where N is the configuration file line number that specifies the Quality Center URL. You may define multiple Quality Center servers in the file, each should have a matching Version.N= line. For a single Quality Center server version 9.0, the second line of the configuration file should be Version.1=90. See “Quality Center Configuration File” for details.

Note: The default Mercury address specified in the configuration file is http://localhost:8080/qcbin.

6. Click Import in the Configuration for ‘Quality Center’ Integration editor to import the contents of another .ini file.
7. Click OK in the text editor and in the Edit Integration dialog box to save the edits.
8. To save the information, select File > Save Changes. To cancel the changes, select Edit > Cancel Changes from the menu.

Note: You must restart your CaliberRM client after you edit and save the configuration file to load new configuration settings.

Quality Center Configuration File

The configuration file consists of three parts: servers list, filters and server versions.

To define Quality Center servers available, you need to specify these servers first, each server on its own line.

To define filters, you need to specify the following string:

filter.<CaliberRM project name>=<number>

where

<number> is a line index of the Quality Center server in the configuration file list, provided in the first section of the configuration file.
Using the Mercury Integration

<Domain Name> and <Project name> are names of Quality Center domains or projects, or they can be asterisks ("*"), if you want to include all possible domains or projects.

If you enable the integration for a CaliberRM project for which no filter is defined, all servers provided in the first section, as well as all domains and projects of these servers will be available.

You need to provide separate filter string for each server in your servers list.

To define server versions, you need to specify the following string:

version.<number>=[82/90]

where <number> is a line index of the Quality Center server in the list, provided in the first section of the configuration file. After the equal sign, you should specify either 82 or 90, depending on the version of the server. You need to provide separate version string for each server in your servers list.

Configuration file example

*** qc_config.txt ***

http://host_1:8080/qcbin
http://host_2:8080/qcbin
http://host_3:8080/qcbin
http://host_4:8080/qcbin

filter.Address Book=1\DEFAULT\QualityCenter_demo;2\*;3\DEFAULT\*
version.1=82
version.2=82
version.3=90
version.4=82

This configuration file specifies that you have 4 Quality Center servers available, and also define that for the CaliberRM project "Address Book" the following Quality Center projects will be available:

server=http://host_1:8080/qcbin, domain=DEFAULT, project=QualityCenter_demo;
server=http://host_2:8080/qcbin, any project in any domain;
server=http://host_3:8080/qcbin, any project in the domain "DEFAULT";
the last Quality Center server will not be available for "Address Book";
server http://host_3:8080/qcbin is a Quality Center 9.0 server, other servers are Quality Center 8.2.

Enabling the Integration in CaliberRM

In CaliberRM Administrator, the Mercury integration must be enabled or disabled at the project level.

To enable or disable the Mercury integration at the project level:

1. In the CaliberRM Administrator, select View > Projects from the menu.
2. Select the project for which you want to enable the Mercury integration.
3. Select the External Traceability tab.
4. Select Quality Center in the Disabled Integration(s) list, and click the left arrow < button. The Quality Center integration moves to the Enabled list. To disable the integration, select Quality Center in the Enabled list and click the right arrow > button.
5. To save the information, select File > Save Changes. To cancel the changes, select Edit > Cancel Changes from the menu.

Using the Mercury Integration

Traceability is established between CaliberRM requirements and the following Mercury objects: requirements, tests, steps or test sets. If you select a "test in set" (in Mercury Test Lab) or a "step in test in
set" (shown when running a test in Test Labs) to trace to a requirement in CaliberRM, the traceability is established between the CaliberRM requirement and the respective tests or steps associated with these "test in set" or "step in test in set" in Quality Center.

Note: The integration creates one connection per Quality Center project (from each CaliberRM client). For example, if you have 2 CaliberRM clients running, and each client is connected to 2 Quality Center projects, a total of 4 connections to Quality Center are established.

Important change in Mercury traceability

Note: This change only applies to customers upgrading from v2005 Release 2 (8.0) or earlier. It does not apply to customers upgrading from 2005 Release 2 SP1 (8.1).

A trace previously created between a requirement and a Quality Center test in set is upgraded to a trace between that requirement and the design test to which the test in set is linked in Quality Center. To be consistent with the Mercury usage model, when a CaliberRM user creates a new trace between a CaliberRM requirement and a Mercury test in set, the trace is established between the requirement and the respective design test linked to that test in set in Quality Center.

Once you upgrade your server to this release, the Document Factory keywords available for reporting on Mercury traces are <<ALL OBJECTS>>, <<VENDOR_OBJECTS>>, and <<TRACE_TESTSTATUS>>.

Linking Requirements to Mercury Objects

To create a traceability link from a CaliberRM requirement to a Mercury object:

1. Select the requirement for which you want to create a trace.
2. Click the Traceability tab.
3. Click the Modify button. The Traceability Modification window opens.
4. Select the Quality Center tab.
5. Select the Requirements, Test Plan, or Test Lab tab to trace the selected requirement to a corresponding Mercury object.
6. Select a server name from the list of available Mercury servers. CaliberRM connects to the Mercury server.
7. Select a Mercury domain. CaliberRM connects to the Mercury domain.
8. Select a Mercury project. CaliberRM connects to the Mercury project.
9. Select a Mercury object to which you want to trace a CaliberRM requirement.

Note: When you access a Mercury project for the first time, the Login to Quality Center Server dialog box displays. Specify a valid user name and password to access the Mercury server. You can also define a default credential to be used to access all Mercury projects. Note that you must select this checkbox if you want to run a Datamart report in silent mode, so that no login dialog is displayed during the Datamart extraction. Refer to the UsingDatamart.pdf guide for details.
10. Select Trace > Trace To from the menu to create a traceability link from a CaliberRM requirement to a Mercury object.

Note: You can create a traceability link from a Mercury requirement to a CaliberRM requirement selecting Trace > Trace From from the menu.
11. Repeat steps 9 and 10 to create any other traces as needed.
12. Click the Save button to save the traces, or click the Cancel Changes button to cancel the traces.
13 Close the Traceability Modification window to return to the Traceability tab. The Mercury traces display with the Mercury object status.

14 If the Comment dialog box is displayed, enter a comment about the change and click OK.

The following information about a linked Mercury object is listed on the Traceability tab:

- **Object file type**
- **Traces To**: the object name
- **Tag/ID**: Mercury object type
- **Status**: Suspect or not
- **Project**: the Mercury project name

If the Mercury integration becomes disabled for your project, or the Mercury server becomes disconnected, existing Mercury traces appear unavailable.

You can right-click a Mercury object in the Traceability tab or the Modify Trace window to select the Properties context menu item and see the corresponding object Properties dialog box.

Note: The Mercury integration automatically updates traces created using earlier versions of CaliberRM except traces to Test Sets. You need to recreate traces to Test Sets.

### Viewing Traces to Mercury Objects in the CaliberRM Traceability Views

Besides the Traceability tab, you can view Mercury traces in the CaliberRM Traceability Matrix. To see Mercury traces you must filter the matrix. You can configure the matrix to have requirement information in the rows and Mercury information in the columns or vice versa.

To view Mercury objects on the Traceability Matrix:

2. Select View > Filter from the Traceability Matrix menu. The Traceability Filter window opens to the CaliberRM Projects tab.
3. Click the Quality Center tab to select to display Quality Center tests in rows or columns.
4. Click OK. The Mercury filtered view displays.

Note: If you have Quality Center servers using multiple versions of Quality Center, you can still create traces to Quality Center objects located in these Quality Center servers from a CaliberRM requirement but only traces to the server for which you have installed the Quality Center connectivity software on your machine will be displayed in CaliberRM. For traces to a server with a version different from the Quality Center connectivity software version installed, you will receive the following message: "Quality Center libraries installed are incompatible with Quality Center version you are trying to connect to. CaliberRM may not work with this server."

For more information on the Traceability Matrix, see “Traceability” in the *CaliberRM User Guide*.

You can also view Mercury objects in the Traceability Diagram. For more information on the Traceability Diagram, see “Traceability” in the *CaliberRM User Guide*.

### Reporting on Quality Center Requirements and Test Execution Status

You can include Mercury requirement status or test execution status in a document generated by Document Factory. For more information, see “Document Factory Syntax” in the *CaliberRM User Guide*. 
Creating Quality Center Tests From CaliberRM Requirements

The Test Wizard allows you to leverage requirements by creating a Mercury test for each selected requirement. This provides an easy way to create tests from all of your requirements by automating the test creation process in Mercury. Before you can create tests using the Test Wizard in CaliberRM, you must enable the integration with Mercury in CaliberRM Administrator. Refer to “Enabling the Integration in CaliberRM” section above.

Note: Make sure only one user runs the test Wizard at once to avoid Mercury errors when concurrently publishing information from two different users.

Note: Quality Center does not support requirement names containing non-alphanumeric characters such as #, $, &, < and so on, so you should update the names of CaliberRM requirements that include such symbols before running the wizard.

To select the requirements for which you want to create tests:

1. In CaliberRM, select Tools > Test Wizard from the menu. The Select Requirements to Test screen displays.

Note: By default the Test Wizard exports the requirements from the currently selected CaliberRM project and baseline. To change the CaliberRM server, project, or baseline to select requirements from, click Back. The Connect To CaliberRM Server screen displays. Enter the data you want to modify.

2. Select the requirements for which you want to create tests. If you select a parent requirement, all child requirements are automatically selected. Clear the child requirements you do not want to test.

Note: When publishing requirements, CaliberRM automatically creates traces between the requirements and the Mercury tests published.

3. Click Next. The Connect to Quality Center screen displays.

4. Select a Mercury server name from the Host drop-down list.

5. Click the Connect button to display the list of domains available on the selected Mercury server.

6. Select a domain to display the list of projects available in the domain.

7. Select a project.

8. Provide a valid user name and password to access the Mercury server.

9. Click Next. The Select The Components For The Test Name screen displays.

10. Select the options for your Test Name.

Note: Requirement Name is the default.

Prefix: adds your choice of prefix for the requirement to the test name.

Requirement Tag: adds the requirement’s unique type tag to the test name.

Requirement ID: adds the requirement’s unique ID to the test name.

Requirement Name: adds the requirement name; default.

11. Click Next. The Select The Components For The Test Description screen displays.

12. Select the components you want to add to the test description.

Requirement ID: adds the requirement’s unique ID to the test description; CaliberRM requirement ID is the default.

Requirement Name: adds the requirement’s name to the test description; CaliberRM requirement name is the default.

Requirement Description: adds the requirement’s description to the test description; CaliberRM requirement description is the default.

Note: The Test Wizard publishes requirement descriptions in plain text in tests it creates. The rich-text description of published requirements is available as HTML attachment to the requirement in Quality Center.
Validation: adds the requirements Validation tab text to the test description.

1. Click Next. The Customize Fields screen displays.
2. Select the UDA you want to add to the list of user-defined fields of your test details.
   Note: CaliberRM ID, CaliberRM Owner, CaliberRM Version, CaliberRM Status, CaliberRM Baseline are the default fields.

   Force updating fields: updates all user-defined fields for the test every time you run the Test Wizard, even if the requirement version is the same. When this checkbox is not selected (default), only requirements with newer versions (which have been modified since the last time the Wizard was run) are updated. If this checkbox is selected, all requirements are updated, regardless of their versions. For example, you want to check this box, if you add some UDAs to be published, and want these UDAs to be updated for all requirements, even for those that were not changed.
3. Click the Move right button.
4. Repeat steps 14 and 15 to include additional UDAs.
5. Click Next. The Assign The Test To A Folder screen is displayed.
6. Click Select All, or select individual tests to assign to separate folders.
7. Click Assign Folder for each selected test.
8. Select the test folder to place your test in.
9. Click Finish. The Progress Status Window screen is displayed, and shows the status of each test created from requirement once the progress is complete.
10. Click Done. The Test Wizard closes.

Creating Quality Center Requirements From CaliberRM Requirements

The Publish Requirements Wizard allows you to publish requirements created in CaliberRM to the Requirements section of Mercury.

The Publisher automatically maps existing CaliberRM fields to existing system fields in Quality Center as follows:

- Name – Name (in Quality Center outline)
- Description – Description (in Quality Center)
- Project – Product (in Quality Center)
- Requirement Type – Type (in Quality Center)
- Priority – Priority (in Quality Center)

Additionally, the integration maps existing CaliberRM fields to user-defined fields in Quality Center. Note that the Publisher creates these fields the first time the publisher is run (assuming the user launching the Publisher has user-defined customization rights in Quality Center) and does not use user-defined fields created in Quality Center ahead of time.

- CaliberRM Baseline – next available user defined field
- CaliberRM Owner – next available user defined field
- CaliberRM Version – next available user defined field
- CaliberRM ID - next available user defined field
- CaliberRM Status - next available user defined field

All of these Quality Center user defined fields created by the integration are of type=string.

Note: Before you can publish requirements follow the steps in the “Enabling the Integration in CaliberRM” above to enable the integration with Mercury in CaliberRM Administrator.

To select the requirements that you want to publish to Mercury:
1 In CaliberRM, select **Tools > Publish To Quality Center** from the main menu or click the Publish to Quality Center toolbar button.

Note: By default the Wizard publishes the requirements from the currently selected CaliberRM project and baseline. If you want to publish other requirements than those in the currently open baseline, click Back. The **Connect To CaliberRM Server** screen displays. Enter the data you want to modify.

2 Select the requirements you want to publish from CaliberRM.

   **Note:** Unselect ‘Add traces to published requirements’ checkbox if you do not want the traces to be created in CaliberRM for the requirements published to Quality Center. By default, this option is checked.

   **Note:** If you select a parent requirement, all child requirements are automatically selected. Clear the child requirements you do not want to publish. If you select children requirements and do not select their parent, parent requirements will be created in Quality Center. However if in a subsequent publisher session, you do select the parent, its children requirements will be relocated to be below their parent.

   **Note:** The Publish Requirements Wizard places plain text in requirements it publishes. No images or URL included in a requirement description display in Mercury.

1 Click **Next**. The **Connect to Quality Center** screen displays.

2 Select a Mercury server name from the **Host** drop-down list.

3 Click the **Connect** button to display the list of domains available on the selected Mercury server.

4 Select a domain to display the list of projects available in the domain.

5 Select a project.

6 Provide a valid user name and password to access the Mercury server.

7 Click **Next**. The **Customize Fields** screen displays.

8 Select the UDA you want to publish.

   The Publisher uses Quality Center user fields of type String. If you want to publish a multiline text UDA (which may be longer than the length of a String field in Quality Center), prior to publishing the requirements, consider changing the Notes User field in Quality Center as follows:

   a in Quality Center, select **Customize field entities**

   b select **REQUIREMENT > User Fields**

   c select the **Notes** field and change its type from String to Memo

   **Note:** CaliberRM ID, CaliberRM Owner, CaliberRM Version, CaliberRM Status, CaliberRM Baseline are the default fields.

   **Note:** Corresponding Mercury User Defined Attribute (UDA) gets deleted when that field is unselected (Customizing Fields Dialog) during the Publish Requirement /Test Export process.

   **Force updating fields:** updates all user defined fields for the test every time you run the Publish Requirements Wizard. When this checkbox is not selected (default), only requirements with newer versions (which have been modified since the last time the Wizard was run) are updated. If this checkbox is selected, all requirements are updated, regardless of their versions. For example, you want to check this box, if you add some UDAs to be published, and want these UDAs to be updated for all requirements, even for those that were not changed.

1 Click the **Move right** button.

2 Repeat steps 10 and 11 to include additional UDAs.

3 Click **Next**. In the **Select Root** step, select the Quality Center node you want to publish requirements under. The roots in the list are marked as follows:

   • Red mark means: you cannot publish the baseline because another baseline of this project is already published in this root

   • Green mark means: you can republish the same baseline that was published previously to that folder. You can also choose another node to publish the same baseline. In this case, the requirements will be moved to the currently selected node.
To create a new Root, create the Root in Quality Center.

4 Click **Next**. The **Publish Requirements** screen displays each selected requirement with its respective publishing status as follows:

- **Created** – the requirement was created in Quality Center
- **Failed** – an error while creating requirements (description of the error is displayed in the PublishRequirementsWizard.log file)
- **Up-to-date** – requirement was not updated because it was not changed in CaliberRM since last import
- **Updated** – Quality Center requirement was updated with the latest CaliberRM requirement’s data
- **Reordered** – requirement was moved to appropriate parent/position, according to its current position in CaliberRM

5 Click **Done**. The Publish Requirements Wizard closes.

---

Note: You cannot edit Mercury requirements unless you get the permission to modify Mercury requirements from your Mercury administrator. We recommend that you edit the requirements in CaliberRM and republish them to Mercury to keep requirements in both tools synchronized.

Note: You can publish the same set of CaliberRM requirements to Mercury several times, which updates them.

Once published, you can view in Quality Center the baseline information (in the CaliberRM Baseline field, and the requirement version in the CaliberRM Version requirement field. If requirements are deleted in CaliberRM and a baseline who contained these requirements is republished, the deleted requirements are not deleted in Quality Center (as test assets may have been associated with the deleted requirements). You can manually delete these requirements.